Comcast IPv6 with Ubiquiti EdgeRouter

With the latest release of firmware (1.6) for Ubiquiti EdgeRouter devices, you can now use DHCPv6-PD with only modifying the device config.

It works with Comcast’s IPv6. Here’s my config to get you going:

 

Click to share: Share on FacebookShare on Google+Share on RedditTweet about this on TwitterPin on Pinterest

7 thoughts on “Comcast IPv6 with Ubiquiti EdgeRouter”

  1. I just got my Ubiquiti Edgerouter (the 5 port POE one) and was looking into an up-to-date Comcast IPv6 howto.

    I guess this config would help me get there, but I’m still trying to figure out a probably pretty basic question: how do I actually use these config directives? Save my current one using the webinterface and somehow merge them? Is there one on the device itself I can edit via SSH?

  2. Currently working through your helpful guide, thanks for posting this. That said, it sure would be nice if you could post the config in the show configuration commands format.

    1. Andrew,

      At this point, it’s probably a little late for that since my router’s configuration has changed quite a bit since then.

      In the future, I’m actually thinking about a tutorial to take an ER from the default out-of-the-box configuration to a useful one for use with Comcast’s IPv6, but that won’t happen for a while.

      Let me know if you need help inputting the configuration.

  3. Have you tried this with 1.7 yet? I have 1.7 on my ER, which uses wide dhcpv6, and that fails to retrieve a prefix.

    If I manually used ISC dhclient which is in the base operating system, then I am able to get a prefix, however, thats clunky and requires a lot of tinkering with config files.

    Not knowing what Ubiquiti have changed between versions, makes me wonder if perhaps there has been a regression?

Leave a Reply

Your email address will not be published. Required fields are marked *